SWOS 2020 - bug reports

More
5 months 1 week ago #145664 by Sprudel
Replied by Sprudel on topic SWOS 2020 - bug reports
Thanks @Playaveli for you suggestions. Yesterday evening I had again a chance to look into it.
I have to admit that I have concealed one detail about my setup: I am using Amiga OS 3.2 which recently came out.
Yesterday I re-configured my MIST FPGA to use an Amiga 1200 typical setup but this time with OS 3.1, I was loading the ADFs and: it worked as expected. So it looks like the SWOS 20/21 setup is just not yet compatible with Amiga OS 3.2.
As said the old SWOS 97/98 WHDLOAD version also works with OS 3.2.
For now I am happy to be able to play SWOS 20/21 on my MIST FPGA but I hope it will become compatible with OS 3.2 as well in the near future so I don't need to switch (and reload) my Amiga configuration.
Feel free to involve me for any kind of testing btw.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #145665 by Clovis62
Replied by Clovis62 on topic SWOS 2020 - bug reports
Hi guys !
Bench problems have been solved . Great !!

But with 3.0.12, in PC config, screen freeze when typing several keys . For example, during a game, after a kick off, all was blocked :( The only way to escape is by using esc key, but you loose the current game :( :(

Another wrong thing : in career Mode, if you are coaching a temm playing UEFA cup, the first round is always against a team of your championship
Panathinaikos vs Aek Athen, Salzbourg Red Bull Vs Linz, etc... May be a random to secure.

Great job! See u Soon for a play :) Up the Irons !

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #145666 by starwindz
Replied by starwindz on topic SWOS 2020 - bug reports

Hi guys !
Bench problems have been solved . Great !!

But with 3.0.12, in PC config, screen freeze when typing several keys . For example, during a game, after a kick off, all was blocked :( The only way to escape is by using esc key, but you loose the current game :( :( !

this issue is completely reproducible? and can you share some kind of recorded video of this issue? this issue does not happen on my pc

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #145667 by Clovis62
Replied by Clovis62 on topic SWOS 2020 - bug reports
this happens when multiple keys are pressed or remain pressed during a cinematic. For example, when a foul is called or a corner must be taken. at this time, the game is stopped. It is the same when a red card or a yellow card is given. As far as I know the coding, we can say that after a standard kinematics (action of the referee, out of play ball ...) the hand is not given to the player. The player is out of the loop.
My last bad experience was after a shot on goal, the player goes to the point to shoot but I have no more control: can not go left nor right nor shoot .. It is not a processor problem, because the fans on the stands continue to move. Only the penalty taker is frozen: /: /: /
the only key that works is 'esc'. no player changes, no stats or highligths. :/ :/ :/
Hope it can helps you
Good Luck !

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago - 5 months 1 week ago #145668 by starwindz
Replied by starwindz on topic SWOS 2020 - bug reports

this happens when multiple keys are pressed or remain pressed during a cinematic. For example, when a foul is called or a corner must be taken. at this time, the game is stopped. It is the same when a red card or a yellow card is given. As far as I know the coding, we can say that after a standard kinematics (action of the referee, out of play ball ...) the hand is not given to the player. The player is out of the loop.
My last bad experience was after a shot on goal, the player goes to the point to shoot but I have no more control: can not go left nor right nor shoot .. It is not a processor problem, because the fans on the stands continue to move. Only the penalty taker is frozen: /: /: /
the only key that works is 'esc'. no player changes, no stats or highligths. :/ :/ :/
Hope it can helps you
Good Luck !

do you use a kind of "mechanical keyboard?" it looks "keyboard ghosting" issue. can you test your keyboard via this site?
www.microsoft.com/applied-sciences/projects/anti-ghosting-demo
Last edit: 5 months 1 week ago by starwindz.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #145669 by Clovis62
Replied by Clovis62 on topic SWOS 2020 - bug reports
cordless key board. Standard HP Keybord

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #145683 by Clovis62
Replied by Clovis62 on topic SWOS 2020 - bug reports
Hi ! Still frozen screen after a yellow card cinematic. ..
the 's' Key (statistics) works but not the other keys (A, left, rigth, up, down, O,P, tripe up ...)
Whene the referee appears, it seems to block the keybord for thoses keys.
Good Luck
:/ :/

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #145684 by starwindz
Replied by starwindz on topic SWOS 2020 - bug reports

Hi ! Still frozen screen after a yellow card cinematic. ..
the 's' Key (statistics) works but not the other keys (A, left, rigth, up, down, O,P, tripe up ...)
Whene the referee appears, it seems to block the keybord for thoses keys.
Good Luck
:/ :/

It looks a very strange issue. I have never received this kind of report with all version as well as 3.0.12. Could it be possible to test by connecting the keyboard directly to the PC with a USB cable? (Not codeless)

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #145685 by captaincofresi
Minor issue, might be a bug or it's a feature (as it happens in both 2.4.1 and 3.0.12)? When playing a Friendly, and then pressing ESC, then going into Play Again the overview of both teams no longer shows up. It just flashes the attatched Screenshot, instead of showing both teams and their players.
Attachments:

Please Log in or Create an account to join the conversation.

More
5 months 6 days ago - 5 months 6 days ago #145686 by starwindz
Replied by starwindz on topic SWOS 2020 - bug reports

Minor issue, might be a bug or it's a feature (as it happens in both 2.4.1 and 3.0.12)? When playing a Friendly, and then pressing ESC, then going into Play Again the overview of both teams no longer shows up. It just flashes the attatched Screenshot, instead of showing both teams and their players.


In the original DOS or Amiga version, and any version of SWOS 2020, the team overview never appeared after pressing ESC in Friendly mode. And I'm not sure about the screen flickering either. If there is a flicker, it would be very instantaneous.
Last edit: 5 months 6 days ago by starwindz.
The following user(s) said Thank You: captaincofresi

Please Log in or Create an account to join the conversation.

Time to create page: 0.287 seconds
Powered by Kunena Forum